Bones Tutorial
Legal Notices

Corporate Headquarters
5530 St. Patrick, Suite 2210
Montreal, Quebec
Canada H4E 1A8
Tel: (514) 278-8666
Fax: (514) 278-2666
toonboom.com

Disclaimer
The content of this manual is covered by a specific limited warranty and exclusions and limit of liability under the applicable License Agreement as supplemented by the special terms and conditions for Adobe®Flash® File Format (SWF). Please refer to the License Agreement and to those special terms and conditions for details.

The content of this manual is the property of Toon Boom Animation Inc. and is copyrighted. Any reproduction in whole or in part is strictly prohibited. For additional copies of this manual, please contact Toon Boom Animation Inc. at the Corporate Headquarters address.

Copyright © 2011 by Toon Boom Animation Inc. All rights reserved.

Trademarks
Toon Boom Studio is a trademark owned by Toon Boom Animation Inc. All other trademarks are the property of their respective owners.

Credits
Documentation Development: Peter Cawthorne
Content Development: Marie-Eve Chartrand, Anouk Whissell, Shabana Ali
Art Development: Marie-Eve Chartrand, Anouk Whissell, Shabana Ali, Tania Gray, Natalia Solari, Annie Rodrigue

Publication Date
February 2011
Published by Toon Boom Animation Inc.
Chapter 1: Introduction .................................................................................................................................................3
  Documentation .........................................................................................................................................................4
  Toon Boom Studio - How To? .................................................................................................................................4
  Workout Series ......................................................................................................................................................4
  Video Lessons .......................................................................................................................................................4
  Tutorials .................................................................................................................................................................4
  Articles ..................................................................................................................................................................5
  Templates ..............................................................................................................................................................5
  Remember to Register Toon Boom Studio ...........................................................................................................5
  Get Help! ..............................................................................................................................................................6
  Knowledge Base ..................................................................................................................................................6
  User Forum ...........................................................................................................................................................6
  Animation Glossary ................................................................................................................................................6

Chapter 2: Bones Tutorial ................................................................................................................................................7
  About the Skeleton Effect .......................................................................................................................................8
  Bone Tools Toolbar ...............................................................................................................................................9
  Setup Mode ..........................................................................................................................................................9
  Animation Mode ................................................................................................................................................10
  Choosing Your Character ........................................................................................................................................11
    Planning and Preparing Your Character .......................................................................................................11
    Creating a New Project and Importing a Character ......................................................................................12
  Building the Skeleton ...........................................................................................................................................13
    Setting up the Timeline ......................................................................................................................................13
    Adding Bones ....................................................................................................................................................14
    Setting Up the Bones .......................................................................................................................................16
      Resetting the Position .......................................................................................................................................18
    Setting the Influence Area ................................................................................................................................19
      Influence Area ................................................................................................................................................19
      Elliptical or Infinite Influence Areas ...........................................................................................................20
      Modifying the Size of the Influence Area ..................................................................................................21
    Parenting Bone Chains ...................................................................................................................................22
  Animating the Skeleton .........................................................................................................................................24
    Reassembling the Character ............................................................................................................................24
    Ordering Limbs ..................................................................................................................................................26
      Character on a Single Drawing Layer .........................................................................................................26
      Character with Limbs on Different Drawing Layers ....................................................................................27
    Hiding Bones ....................................................................................................................................................27
    Animating Bones ...............................................................................................................................................28
      Onion Skin Toolbar ..........................................................................................................................................30
      Blocking the Body’s Position ..........................................................................................................................30
      Deleting Keyframes ........................................................................................................................................30
      Removing All Keyframes .............................................................................................................................31
      Adjusting the Velocity and Functions ..........................................................................................................31
      Disabling a Bone Animation ..........................................................................................................................32
  Skeleton Effect Properties ......................................................................................................................................33
  Preferences ............................................................................................................................................................35
  What You Have Learned .......................................................................................................................................36
Toon Boom Studio is a multi-technique, vector-based animation software that you can use for all your projects. It is a dynamic and exciting software with leading edge features based on industry proven technology. Toon Boom Studio is also ideal for learning animation.

Toon Boom Studio allows you to produce at least five different styles of animation:

- Traditional Animation
- Traditional Digital Animation
- Cut-out Animation
- Stop-motion Animation
- Rotoscoping
- Bone Animation

This tutorial focuses on the Bone animation technique. To follow this tutorial, it is expected that the user knows the Toon Boom Studio basics.
Documentation

In addition to this tutorial, there are other useful documents available. Learn how to use Toon Boom Studio with our easy-to-use documentation package:

• **Integrated Help**
  In Toon Boom Studio, select **Help > Toon Boom Studio Help** to open the help system in your default browser.

• **Context-Sensitive Help (Tooltips)**
  To get a short description of a menu command or toolbar button, select **Help > What’s This** and click on the item. A tooltip pop-up window opens with the description of the item you clicked on.

Documentation and additional tutorials for Toon Boom Studio are available on the Web via the Toon Boom website’s **How To** section.

Select **Help > Toon Boom on the Web** to open the Toon Boom website in your default Web browser.

**Toon Boom Studio - How To?**

Toon Boom’s How To tools, available at www.toonboom.com, help you to broaden your Toon Boom Studio and general animating skills. Choose from basic to advanced tools to take your animation know-how to the next level. You can also open the How To page from Toon Boom Studio:

Select **Help > Toon Boom on the Web** to open the Toon Boom website in your default Web browser.

**Workout Series**

The Toon Boom Animation Workout Series is a dedicated program of exercises designed to help you develop the skills and techniques necessary to get the most out of Toon Boom Studio.

**Video Lessons**

The Toon Boom Studio Training Video is the perfect way to get first-hand instructions on how to use the software. Nearly one-hour long, these Training Videos cover all aspects of the user interface, content creation, artwork import, animation techniques (traditional and keyframe), scene planning and special effects.

**Tutorials**

Video and print tutorials will get you started and introduce you to the application one step at a time.
Articles

These valuable tips and application ideas can be used to familiarize and help you understand the creative potential of Toon Boom Studio.

Templates

Use the ready-made templates to create an animation quickly and easily, while learning how to draw and animate in the Cut-out style!

Collections of characters and props are available in our online store.

Remember to Register Toon Boom Studio

Register now! Become a member of the Toon Boom community!

Membership has its benefits:

• Priority email announcements
• Toon Boom enews
• Update information.
• Upgrade discounts.
• Access to support tools.
• Submit your masterpieces to our Showcase.
Get Help!

Knowledge Base
Find answers to your Toon Boom Studio questions in the Knowledge Base on our website at: http://www.toonboom.com/support/kb/categories/Toon-Boom-Studio.

User Forum
Registered Toon Boom Studio members can access and post on the User Forum. Or view the Forum content as a guest.

Animation Glossary
A comprehensive glossary of terms is available on the Toon Boom website. Access it through the Knowledge Base at: http://www.toonboom.com/support/kb/.
The Bones feature in Toon Boom Studio allows you to create a skeleton over your character by using the different Bone tools and then animate it as if it were a body with the Skeleton effect. The skeleton can be used to not only animate vector-based drawings but also bitmaps.

This tutorial is divided as follows:

- About the Skeleton Effect, on page 8
- Choosing Your Character, on page 11
- Building the Skeleton, on page 13
- Animating the Skeleton, on page 24
- Skeleton Effect Properties, on page 33
- Preferences, on page 35
- What You Have Learned, on page 36

You can follow the different exercises of this tutorial using the various bones templates provided in the software’s library!

You can find these templates inside the Library view by following this structure:

- Toon Boom Templates > Bones
About the Skeleton Effect

The Toon Boom Studio Skeleton effect is used to create an animatable bone structure in a character or design. The structure will let you bend a limb, automatically creating a joint with a distortion of the artwork such as the arm example above. The arm is drawn straight on a single flattened drawing, the skeleton effect automatically creates the elbow joint.

Since the bones act as pegs, when you animate the arm bending, for example, the motion will be automatically interpolated if your keyframes are set to non-constant.

🔍 In the Studio User Guide, refer to the following topics of the Animating a Puppet chapter to learn more about peg animation concepts:
  • Understanding Keyframes and Drawings
  • Constant and Non-Constant Segments
  • Adjusting the Velocity
  • Using the Onion Skin in Cut-out Animation

💡 Once you gain confidence, you can also use your creativity and try the Skeleton effect on other animatable designs other than limbs to create some interesting distortion effects, like this animated smiling fish!
**Bone Tools Toolbar**

By default, the Bone Tools toolbar is located just below the Sceneplanning Tools toolbar on the left side of the application. Use these tools to create, setup and animate your bone structure. You have two types of tools, setup mode tools and an animation mode tool.

It is very important to understand that when selecting a Bone tool, the camera display and Skeleton Effect will automatically switch to either setup mode or animation mode.

**Setup Mode**

The setup mode is on when you are using tools to setup the initial bone structure of the skeleton. Moving bones around with these tools will not create keyframes or animation on the Timeline.

When in setup mode, a large circle appears at the base of your bones.

*This circle is only visible when in setup mode.*

These are the setup bone tools, selecting any of these will switch the Skeleton Effect to setup mode:

- **Bone Setup tool**
  This tool is used to position the selected bones on your drawing. Use this tool to drag, rotate and scale a bone or a hierarchy of bones.
  You can also select this tool using the top menu, select Tools > Bone Tools > Bone Setup or use the default keyboard shortcut [J].

- **Bone Creator tool**
  This tool is used to add bones to your bone structure. When a bone is selected, the newly created bone will be automatically parented to it.
  You can also select this tool using the top menu, select Tools > Bone Tools > Bone Creator or use the default keyboard shortcut [U].

- **Bone Influence tool**
  This tool is used to determine the size of the area around the selected bone that will be influenced by the Skeleton effect. By default, this zone is visible and appears as a large ellipse around each bone.
  You can also select this tool using the top menu, select Tools > Bone Tools > Bone Influence.

- **Bone Parent tool**
  This tool is used to parent different bone chains to one another.
  You can also select this tool using the top menu, select Tools > Bone Tools > Bone Parent.

Refer to the Building the Skeleton topic to learn how to use these tools.
Animation Mode

The animation mode is automatically on when you select the Bone Manipulator tool. This means that the Camera view will display the current pose of the bone structured puppet animation at the selected frame and any manipulation you make will create a keyframe on your Timeline and be animated.

When in animation mode, you will notice that the large circle you can see at the base of the bones in setup mode disappears.

There is no circle displayed when in animation mode.

- **Bone Manipulator tool**
  This tool is used to create the animation of your bone structured puppet. You can drag, squash, stretch, rotate or scale a selected bone chain, creating an animation keyframe on your Timeline.
  You can also select this tool from the top menu, select **Tools > Bone Tools > Bone Manipulator** or use the default keyboard shortcut [H].

Refer to the Animating the Skeleton topic to learn more about this tool.
Choosing Your Character

Before building your puppet’s skeleton, the first thing you need to do is to select and prepare your character. In just the same way when building a cut-out puppet, if this is your first puppet it is always better to choose a simple character. A simple character has two legs, two arms, a head and torso. To begin with, you should avoid a character with too many loose clothes such as a cloak or baggy pants. As you progress and gain experience creating and animating skeleton puppets, you will learn what to do to optimize your animation and workflow.

We chose a skeleton pirate character to demonstrate how to use the Skeleton effect and Bone tools.

You could also create your character from a picture or a bitmap image.

Planning and Preparing Your Character

When choosing and preparing your character, it is recommended that all parts of the character be separated in space. This is to ensure the cleanest articulation between character pieces when animating bones affected by elliptical influence areas. It is also recommended to group each of the separate parts and properly arrange the ordering of these limbs and body groups inside the drawing.

![Bad and Good Examples](image)

In the Studio User Guide, refer to Chapter 4: Drawing and Design to learn about the Drawing tools and options.
This is an example of what could happen if a character’s limbs were overlapping during setup (Figure A), versus one whose limbs were separated from the body during setup (Figure B).

Since the Skeleton effect will be applied to any art contained inside a bone’s influence area in setup mode, the following happens:

- **Figure A.** The character’s shoulder in this example was overlapping the body at setup. Therefore, animating the shoulder will also move any part of the torso that was included in the influence area.
- **Figure B.** The character’s shoulder was not overlapping the torso during setup, so no part of the torso will be influenced by the animation of this bone.

You can have all your character’s parts drawn on the same drawing element, or you could also separate the different parts so that each is on a different drawing layer. For example, you could have five drawing elements for your character; one for the body and head combined and one for each of the four limbs. Drawing each part on a separate element simplifies the process of ordering the limbs later.

Refer to the Building the Skeleton and Animating the Skeleton topics to learn more.

**Creating a New Project and Importing a Character**

The best way to build the skeleton for your character is to create a new scene and import the character into the scene. There are several ways to import your character in a scene:

- You can create a template using the Library and import it in your new scene
- Import a bitmap image
- Scan a drawing
- Import a picture, etc.

If you import a picture, make sure to import it in a Vector element and not an Image element so that you can edit the character and animate it using the skeleton effect.

Refer to the following Studio User Guide topics to learn more about creating projects, scanning your drawings, importing bitmap images and photos, creating templates and importing templates:

- Starting Your Project - Creating and Opening a Project
- Importing Artwork - Scanning Images
- Importing Artwork - Importing Bitmaps Images
- Importing Artwork - Library
Building the Skeleton

Once your character design is ready, you can start building the structure of the puppet’s skeleton. Here are the different steps and tools:

- Setting up the Timeline, on page 13
- Adding Bones, on page 14
- Setting Up the Bones, on page 16
- Setting the Influence Area, on page 19
- Parenting Bone Chains, on page 22

Setting up the Timeline

To create the skeleton for a puppet, you must first add a Skeleton Effect in your Timeline and connect your character’s artwork to it.

To add a Skeleton effect:

1. In the Timeline view, click on the Add New Elements button.

   ![New Elements dialog box](image)

   The New Elements dialog box opens.

2. From the Type drop-down menu, select Skeleton Effect.

   ![Skeleton Effect Type](image)

3. In the Name field, give a name to the Skeleton Effect element.

   ![Name field](image)

4. Click on the OK button.

   The Skeleton Effect appears in your Timeline.
5. Select and drag the drawing layer containing your character onto the Skin Group. This is where you connect any art layer you want to be influenced by the bones. Make sure to drop the drawing layer directly on the Skin Group to parent them.

If your character’s parts are drawn on different elements, make sure to parent all the drawing elements to the Skin Group.

Once layers are parented in the Timeline view, you can click on the blue triangle icon to collapse or expand them. This is useful when the Timeline view becomes filled with layers.

You can add any drawing layer to the Skin Group or remove any drawing layer from it at any time; this makes it handy to reuse. You could reuse a bone structure saved in your library with other character designs! In the Studio User guide, refer to Chapter 6 Importing Artwork - Library to learn more about using the Library view.

Adding Bones

Once you have added a Skeleton Effect in your Timeline view and connected your character drawing layers to it, you can start adding bones.

When creating your bone structure, think about where you want the limb to bend. Just as in this example, there should be three bones and two joints; the elbow and the wrist.

To add bones to your character:

1. Make sure you are working in the Camera view.
2. In the Timeline view, select the Skeleton Effect top layer.
3. From the Bone Tools toolbar, select the Bone Creator tool. You can also use the keyboard shortcut [U].
4. In the Camera view, click and drag to create the first bone, following your character design.

If you do not position the bone perfectly the first time, you can fix it later using the Bone Setup tool. Refer to the Setting Up the Bones topic to learn how.

5. Once you have created a bone, it automatically becomes selected. A selected bone appears red in colour. The next bone you will create will be automatically linked and parented to the currently selected bone. This creates a chain linked by a joint.

As you create bones, you will notice that a new bone layer is automatically added for each one of them in the Timeline view under the Bone Group. You can see the different hierarchies you created. Note that Bone layers act just like Peg layers.

Once you have the first bone, that you created by dragging the whole length of the bone (from start point to end, then letting go) the following bone is created just by clicking the end point of the next limb and dragging to resize.

In the Studio User Guide, refer to the Layers and Timing chapter to learn more about layers.
6. Once you finish creating the bone structure on a first limb, in the Timeline view, select the top layer of the Skeleton Effect, this will let you start the bone structure for the next limb. Then, repeat Step 4 and Step 5 until a bone structure is created for each of the body parts.

This character’s bone structure is complete. Notice how each of the body parts, including the body of the character, are independent from each other. They are all separate bone chains and are not connected to each other.

Setting Up the Bones

Once you start creating bones you can, at any time, modify them in setup mode to optimize their positioning without creating an animation.

To modify bones using the Bone Setup tool:

1. From the Bones Tools toolbar, select the Bone Setup tool. You can also use the keyboard shortcut [J].
2. In the Camera view, select the bone you want to modify.

   The selected bone becomes red and two control handles appear.
To rotate the bone, place your cursor over the bone until you see the rotation cursor. Click and drag to rotate the selected bone. You can change the rotation angle of any of the bone in the chain.

To lengthen or shorten the bone, click on the round handle at the tip of the bone and drag to shorten or lengthen it. You can lengthen or shorten any bone in your chain.

To reposition the bone, click on the square handle and drag it the desired position.

You should only reposition the first parent of the bone chain to avoid creating gaps in your joints that could result in an unwanted distortion of the art.
Toon Boom Studio Bones Tutorial

You can also use the Properties view to define the position of a selected bone.

To modify bones using the Properties view:

1. In the Camera or Timeline view, select the bone you want to modify.
   Its position values appears in the Properties view.

   ![Properties view](image)

   2. In the Properties view:
      - **Position**: Enter the E/W and N/S values to set the position of the selected bone.
        You should not reposition a bone that is not the first parent. This will prevent gaps from forming at the joint area, creating an unwanted distortion of the art.
      - **Length**: Enter a value to set the length of the selected bone. You can resize any bone from the chain.
      - **Rotation**: Enter the number of degrees to modify the rotation angle of the selected bone. You can change the rotation angle of any bone from the chain.

Resetting the Position

You can reset the position of a selected bone at any time using the Properties view. You can also reset the selected bone’s position and rotation values to default.

To reset the position of bones:

1. In the Timeline view, select the bone you want to reset.
2. In the Properties view, set the Position and Rotation values to 0.
3. Repeat these steps for any other bones which you need to reset the position of.

You can also use the Reset option to reset both the bone positions and keyframes simultaneously.

To reset the position of bones and clear keyframes:

1. In the Timeline view, select the bone element you want to reset. You can perform a multi selection and reset the position of multiple bones at the same time.
2. In the Timeline View menu, select Reset. You can also right-click (Windows) or [Ctrl] + click (Mac OS® X) in the right or left section of the Timeline view and select Reset from the pop-up menu.
Setting the Influence Area

The influence area is the zone that defines which art will be included in the Skeleton effect and will be distorted when animated.

Once you setup the bone structure, you need to adjust the influence area of your bones.

This topic is divided as follow:

- Influence Area, on page 19
- Elliptical or Infinite Influence Areas, on page 20
- Modifying the Size of the Influence Area, on page 21

Influence Area

By default, the influence area is the large ellipse surrounding the length of each bone.

The influence area determines the boundaries inside which art will be affected by the selected bone animation. Any art on a drawing layer that is connected to the Skin Group and appears inside the bone influence area, will follow movement of the bone animation.
When setting the influence area around your bones, you must make sure that no unwanted art is included in the area. Any art included in a bone influence area will follow the animation and be distorted.

Elliptical or Infinite Influence Areas

There are two types of influence area possible for a selected bone, these are referred to as Elliptical or Infinite.

Elliptical

By default, the influence area is set to elliptical, meaning that an ellipse shape determines the boundaries inside which art will be influenced by the selected bone animation. This area can be redefined using the Bone Influence tool or Properties view.

Note that if two influence areas overlap, the bone which is situated lower in the Timeline view’s ordering is the one that will win over the other. Therefore, the influence area of the bone which is situated higher in the Timeline view’s order, will have no influence over the overlapping area.

Refer to Modifying the Size of the Influence Area to learn how.

Infinite

You can set the influence area type for a selected bone to Infinite using the Properties view. When set to infinite, the ellipse disappears from the Camera view. The entire art which is part of the Skin Group and which is not contained inside the Elliptical influence area of another bone, will move with the selected bone animation.
Modifying the Size of the Influence Area

By default the influence area of a bone is set to Elliptical, meaning it is bound within an ellipse shape. When an influence area is elliptical, you can modify the size and shape of this ellipse by controlling the width and length radii.

To setup the influence area using the Bone Influence tool:

1. From the Bone Tools toolbar, select the Bone Influence tool.
2. In the Camera view, select the bone to which you want to modify the influence area. The selected bone appears as red and a black bounding box is displayed around the influence area.
3. Click and drag the handles to resize the influence area.

You can also modify the influence area of a selected bone by using the Properties view.

To modify the influence area of a selected bone using the Properties view:

1. In the Camera view, select a bone.
   The influence area values appear in the Properties view.
   - **Length Radius**: Type the desired value for the length radius.
   - **Width Radius**: Type the desired value for the width radius.
**Parenting Bone Chains**

Once you create the bone structure for your character’s limbs and body you can connect them all by parenting them. This unifies the character and, if you want to, allows the limbs to follow the movements of your character’s body.

This step is very simple, as you only use a single tool, the Bone Parent tool.

**To parent bone chains:**

1. From the Bone Tools toolbar, select the Bone Parent tool.
2. In the Camera view, locate the bone which is the starting point of the limb you want to parent to another chain. In this example, the arm will be parented to the body of the Skeleton.

3. Click on the base of the bone you that you want to parent to another, hold and drag the cursor on the bone you want to parent it to. You will notice a red arrow pointing in the direction you drag it. When a straight line appears beside it, it means that it is ready to connect to the selected bone.
4. Release the mouse to complete the connection.

5. Repeat Step 2 to Step 4 until all your limbs are parented to the body.
Animating the Skeleton

Once you have finished creating your character's skeleton, it is time to switch to the Bone Manipulator tool, reconnect the limbs to the body and animate it.

- Reassembling the Character, on page 24
- Ordering Limbs, on page 26
- Hiding Bones, on page 27
- Animating Bones, on page 28
- Disabling a Bone Animation, on page 32

Reassembling the Character

The first step is to reassemble the character so that the limbs do not appear spread apart, as in Setup mode.

To reassemble the character:

1. From the Bone Tools toolbar, select the Bone Manipulator tool.
   You will notice the Camera view changing to animation mode display.
2. In the Timeline view, make sure that the red marker is at the first frame.
3. In the Camera view, select the main bone of one of the limbs.
4. Use the square handle to drag the bone chain to the desired position.

A keyframe will be added to the limb's bone layer on the first frame, locking its position in time.
5. Repeat Step 3 and Step 4 for each limbs you need to assemble to the body.

When your character is assembled and ready for animation, you should save it in the Library view for future reference, and easy reuse between projects. In the Studio User Guide, refer to Chapter 6: Importing Artwork - Library.
Ordering Limbs

When reassembling your character, you might find a limb that does not appear in the correct order, for example, this arm appears under the body.

The ordering method will differ, depending if your entire character is from a single drawing layer or if your character's pieces are separated on several drawing layers:

- Character on a Single Drawing Layer
- Character with Limbs on Different Drawing Layers

Character on a Single Drawing Layer

When this occurs, it is because the ordering of the bones will determine the ordering of the drawing art that is included in its influence area.

To reorder the bone elements:

1. In the Timeline view, select the layer you need to reorder.
2. Drag the Bone element to the desired position within the Bone Group. Be careful to drop it in-between existing bone element hierarchies and not drop it on one, this would parent them.

Note that the ordering of the Bone elements in the Timeline view is the opposite of the other elements. The higher the bone element is in the Timeline ordering, the further back it will appear in the Camera view.
Character with Limbs on Different Drawing Layers

When this occurs it is simply because the Drawing layer containing the limb in question is poorly ordered in the Timeline view. Simply reorder the Drawing layers from the Skin Group to fix the order.

**To reorder layers in the Timeline view:**

1. In the Timeline view, select the layer you need to reorder.
2. Drag the layer to the desired position within the Skin Group. Be careful to drop it in-between layers and not drop it on a layer, this would parent them.

   ![Timeline View Example](image)

   *Remember that the ordering of the Drawing elements in the Timeline view works as follows: The higher the drawing element is in the Timeline ordering, the closer to the front it will appear in the Camera view.*

   Refer to Chapter 14: Scene Setup - Ordering the Elements Layers - Ordering Layer in the Timeline View to learn more about layer ordering.

Hiding Bones

You might need to hide the bones from the Camera view. If this is the case, simply disable the Bone Group.

**To disable the Bone Group:**

1. In the Timeline view, locate the Bone Group you need to hide.

   ![Timeline View Example](image)

2. Click in the layer's check box to disable it.

   ![Timeline View Example](image)

   *Note that disabling the Bone Group will only hide the bones and will not disable the Skeleton Animation. Refer to Disabling a Bone Animation, on page 32 to learn more.*
Animating Bones

Now that the Skeleton puppet is ready, you can start animating it.

To animate bones:

1. From the Bone Tools toolbar, select the Bone Manipulator tool.
2. In the Timeline view, go to the frame where you want to set the first pose of your puppet.
3. In the Camera view, select the bone you want to animate.
4. When a bone is selected you can:
   - Use the square handle to drag the selected bone to a new position. Note that this handle is only available on the parent bone of a chain.
   - Use the circle handle to squash and stretch the bone.
   - Click directly on the bone and drag the cursor to rotate it.

Repositioning a bone will create a square black keyframe marker in the Timeline view, on the layer of the selected bone.

Scaling a bone will create a downwards pointing, black arrow keyframe marker in the Timeline view, on the layer of the selected bone.

Rotating a bone will create a small upwards pointing, black arrow keyframe marker in the Timeline view, on the layer of the selected bone.
A keyframe is created in the Timeline view. If the Skeleton Effect is collapsed, note that you will not see the keyframe marker.

- If you expand the puppet’s elements by clicking on the arrow next to the master peg element, you will notice a red square on the parent element of the bone you moved, this indicates that a child of this bone has a keyframe.

5. In the Timeline view, go to the frame where you want to set your second keyframe.

6. In the Camera view, animate your character.

7. Repeat this process until all your poses are done.

By default, Toon Boom Studio is set to create non-constant keyframes. This means that the software will automatically create the movement between two keyframes. This can prove to be very handy when animating your skeleton puppet. If in some situations you would rather create each keyframe in the interpolation of your movement, you can set your keyframe to be non-constant.

Refer to Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Constant and Non-Constant Segments, on page 286 to learn more!
Onion Skin Toolbar
You can use the Onion Skin toolbar to help you create your animation. It will let you see the previous and next drawings of your animation as a handy reference while animating.

Blocking the Body’s Position
Once you position your puppet, you can create a keyframe for all the bone elements of your collapsed skeleton and block the complete body at a specific frame.

To block the entire body position:
1. In the Timeline view, select the frame at which you want to block your puppet’s position.
2. Select Element > Peg > Add Keyframe. The default keyboard shortcut is [I].

Deleting Keyframes
To delete keyframes:
1. In the Timeline view, select the keyframe you want to remove.
2. Select Element > Peg > Remove Keyframe. The default keyboard shortcut is [Ctrl]+[R] (Windows) or [⌘]+[R] (Mac OS X).

The selected keyframe will be deleted.
If you select a keyframe on a collapsed layer, all the keyframes for all of that frame’s collapsed elements will be removed.
Removing All Keyframes

You can use the Remove All Keyframes option if you need to delete all the keyframes on one or many selected bone elements.

To remove all keyframes:
1. In the Timeline view, select the bone elements you wish to remove all the keyframes from. You can select many elements at once.
2. In the Timeline View menu, select Remove All Keyframes. You can also right-click (Windows) or [Ctrl] + click (Mac OS® X) in the right of left section of the Timeline view and select Remove All Keyframes from the pop-up menu.

Adjusting the Velocity and Functions

You can adjust the velocity to create ease-in and ease out motions or edit the movement Functions using the Function Editor view. This greatly improves the quality and look of an animation, giving a more organic feel to the movement. You can edit the velocity and function of your skeleton or bones in the Function Editor view.

To display the selected bone or skeleton in the Function Editor view:
1. In the Timeline view, select either your Skeleton Effect master element or the bone element you wish to edit the velocity of.
2. In the Properties view, click on the Function Edit or Edit Velocity button.

The Function Editor view will be displayed and the select bone or skeleton function will be selected.

To learn how to adjust the velocity and functions, refer to:
• Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Adjusting the Velocity, on page 294
• Chapter 14: Scene Setup - Function Editor View, on page 369

To learn more about the Skeleton Effect Properties view options, refer to:
• Skeleton Effect Properties, on page 33

To learn more about the Bone element Properties view options, refer to:
• Setting Up the Bones, on page 16
• Setting the Influence Area, on page 19
Disabling a Bone Animation

You might need to disable the Bone Animation. If this is the case, simply disable the Skeleton Effect.

To disable the Skeleton Effect:

1. In the Timeline view, locate the Skeleton Effect top layer, it is the one with a bone icon.

2. Click in the layer’s check box to disable it.

You will notice that the Camera view will automatically switch to Setup mode display.
Skeleton Effect Properties

When the Skeleton Effect master element is selected, many options are made available to you in the Properties view. Because you can animate the master element of the Skeleton Effect just like the master Peg element of a puppet, many options refer to motion paths.

To learn more about animating trajectories and motion paths, refer to Chapter 14: Scene Setup, on page 335.

You can animate this element using the Sceneplanning tools available in the Sceneplanning Tools toolbar.

Refer to Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Using the Different Sceneplanning Tools, on page 290

- **Name**: Displays the name of the selected Skeleton Effect element.
- **Start**: Displays the first frame number to which a keyframe is inserted on the Skeleton Effect element.
- **Duration**: Displays the duration of the animation of the Skeleton Effect element.
- **Loop Mode**: Displays if the layer is looped.
  Refer to Chapter 14: Scene Setup - Other Options - Change Loops, on page 379 to learn more about looping a peg movement.
- **Edit Velocity**: Click on this button to display the Skeleton Element in the Function Editor view. To learn how to adjust the velocity.
  Refer to:  
  - Animating the Skeleton - Adjusting the Velocity and Functions, on page 31  
  - Chapter 11: Animating a Puppet - Creating a Simple Cut-out Animation - Adjusting the Velocity, on page 294
- **Skeleton Colour**: Click in the colour square to open the Select Colour dialog box. Pick a colour to instantly change the colour of the selected Skeleton Effect elements. The colour will change in both the Timeline and Camera view. You can also change the default colour for each new Skeleton Effect you will add to your project using the Preferences panel. Refer to Preferences, on page 35 to learn how.
• **Show Track**: Enable this option to display the motion path of your animation in the Camera view. Refer to Chapter 14: Scene Setup - Creating a Motion Path - Motion Path, on page 358 to learn how to create a motion path.

• **Show Root**: Enable this option to display the root, which is the centre point of the bone structure. Before the master element of the Skeleton Effect is animated, the center point is situated in the centre of the Camera view.

• **Show Influence**: By default this option is enabled, it lets you see the influence areas of the skeleton’s bones in the Camera view. You can disable this option to hide the influence areas.

• **Vector Quality**: Choosing the vector quality level of your skeleton will either improve or depreciate the result of the bone distortion effect.
  - Highest
  - High
  - Medium
  - Low

• **Scale**: Type in the desired width and height scaling values: 1 = 100%. You can also use the Scale tool from the Sceneplanning toolbar.

• **Keep Proportions**: Enable this option to keep proportions when scaling the skeleton.

• **Skewing**: Type in the desired skewing angle value. You can also use the Skew tool from the Sceneplanning Tools toolbar.

• **Rotation**: Type in the desired rotation angle value. You can also use the Rotate tool from the Sceneplanning Tools toolbar.

• **Apply Pivot to**: Select to which transformation you want to apply the pivot to.
  - Rotation
  - Scaling

• **Constant Z**: This option is disabled by default, which means that when you create a motion path along the Z-axis, the automatic interpolation calculates the X, Y and Z axis values. When it is enabled, the interpolation calculates the X and Y axis values and will keep the Z-axis value as constant. Refer to Chapter 14: Scene Setup - Creating a Motion Path - Motion Path - Constant Z, on page 366

• **Orient to Path**: Enable this option to force the element connected to the path to follow the motion path. Refer to Chapter 14: Scene Setup - Creating a Motion Path - Motion Path - Orient to Path, on page 365
Preferences

When working with the bones feature, you can set the colour preference of the bone display from the Preferences panel.

To open the Preferences panel:
- Windows: Select Edit > Preferences.
- Mac OS X: Select Toon Boom Studio 6.0 > Preferences.

To change the bones colour display:
1. In the Preferences panel, click on the Interface tab.
2. In the Element Colours section, double click on the Skeletons and Bones colour square to display the Select Colour dialog box.
3. Pick a colour in the Select Colour dialog box and click on the Ok button.
4. In the Preferences Panel, click on the OK button.
5. Every new Skeleton Effect that you create will use this colour as its default display in the Timeline and Camera view.

You can also change the colour of an already created Skeleton Effect by using its Properties view. Refer to Skeleton Effect Properties, on page 33 to learn how.
What You Have Learned

So far, you have learned about:

• About the Skeleton Effect
• Choosing Your Character
• Building the Skeleton
• Animating the Skeleton
• Skeleton Effect Properties
• Preferences
Index

A
adding bones 14
animating bones 28
skeleton bones 24
animation mode bones 10

B
blocking body position bones 30
Bone Creator tool bones 9
Bone Influence tool bones 9
Bone Manipulator tool bones 10
Bone Parent tool bones 9
bones adding 14
animating 28
animating skeleton 24
blocking body position 30
Bone Creator tool 9
Bone Influence tool 9
Bone Manipulator tool 10
Bone Parent tool 9
Bone Setup tool 9
chains parenting 22
choosing character 11
different drawing layers 27
disable animation 32
display preferences 35
functions adjusting 31
hiding 27
import character 12
influence area setting 19
size of 21
types of 20
keyframes deleting 30
remove all 31
onion skin toolbar 30
order of limbs 26
planning character 11
position reset 18
preparing character 11
reassembling character 24
setting timeline 13
setting up 16
single drawing layer 26
skeleton

building 13
skeleton effect 8
properties 33
tools 9
animation mode 10
setup mode 9
velocity adjusting 31
Bone Setup tool bones 9

C
copyright 0
deleting keyframes bones 30
different drawing layers bones 27
disable animation bones 32
disclaimer legal 0

H
hiding bones 27

I
influence area bones setting 19
size of 21
types of 20

L
legal notices disclaimers 0
publication date 0
trademarks 0

O
onion skin toolbar bones 30

P
parenting bones chains 22
position
bones resetting 18
preferences bone display 35
properties skeleton effect 33
Publication Date 0

R
remove all keyframes bones 31

S
setting up bones 16
setup mode bones 9
single drawing layer bones 26
skeleton building bones 13
skeleton effect bones 8

T
timelaine setting bones 13
tools bones 9
animation mode 10
setup mode 9